Respuestas

2012-06-06T02:05:00+02:00

Aqui lo tienes:(edito, se me olvido validar que sea positivo ^-^)

 

 Proceso suma
    Definir n,i, resultado, salir Como Entero;
    salir <-0;
    Mientras salir = 0
    Escribir Sin Saltar "INGRESE EL NUMERO:";
    Leer n;
    si n < 0 Entonces
        Escribir " INGRESE UN NUMERO POSITIVO";
    Sino
        salir <-1;
    FinSi
    FinMientras

    resultado <-0;
    para i<-1 Hasta n Hacer
        resultado <-resultado +i
    FinPara
    Escribir "LA SUMA ES: ", resultado;
finProceso

2012-06-06T02:25:19+02:00

Revisa este... Creo que estamos resolviendo el mismo taller jeje

 

Proceso sin_titulo
Escribir "3. SUMA DESDE 1 HASTA EL NUMERO INGRESADO.";
Escribir "";
Escribir "Ingresa un numero:";
Escribir "";
Leer n;
suma<-0;
Para i<-1 Hasta n Con Paso 1 Hacer
suma<-suma+i;
Escribir " ", i;
FinPara
Escribir " + ---" ;
Escribir " ",suma;
Escribir "";
Escribir "* La suma de los numeros de 1 hasta ", n, " es: ",suma;
FinProceso