Ayda con PSeInt... Con ayuda de la sentencia SI (IF) y PARA (FOR) o MIENTRAS (WHILE), realizar un Algoritmo donde se cuente el número de votos que obtuvieron los tres candidatos que Se presentaron, al final se deben mostrar los votos que tiene cada candidato, los votos En blanco y anunciar al ganador. Hay que tener en cuenta que solamente serán 10 Personas las que van a votar Para esto se debe realizar un menú con los tres candidatos y la opción del voto en Blanco: 1. Candidato A 2. Candidato B 3. Candidato C 4. Voto en Blanco Cada vez que se escoja un número o candidato se debe hacer un conteo para mostrar Los resultados finales.

1

Respuestas

2012-06-05T04:58:26+02:00

Lo probé en la última versión del PSeInt, además declare todas las variables y use punto y coma al final para que sirva en la mayoria de lenguajes(creo que en todos pero nunca se sabe ^^), si necesitas más ayuda avisame:

 

 

Proceso Candidatos
    Definir a,b,c,blanco,i,voto Como Entero;
    a<-0;
    b<-0;
    c<-0;
    blanco<-0;
    Escribir "VOTOS";
    Escribir "CANDIDATO A : OPCION 1";
    Escribir "CANDIDATO B : OPCION 2";
    Escribir "CANDIDATO C : OPCION 3";
    Escribir "VOTO BLANCO : OPCION 4";
    para i<-1 Hasta 10 Hacer
        Escribir sin saltar "VOTO ", i, ": ";
        leer voto;
        Segun voto Hacer
            1:
                a<-a+1;
            2:
                b<-b+1;
            3:
                c<-c+1;
            4:
                blanco<-blanco+1;
            De Otro Modo:
                Escribir "OPCION NO VALIDA";
                i<-i-1;
        FinSegun
    FinPara
    Escribir "EL CANDIDATO A OBTUVO: ", a," VOTOS";
    Escribir "EL CANDIDATO B OBTUVO: ", b," VOTOS";
    Escribir "EL CANDIDATO C OBTUVO: ", c," VOTOS";
    Escribir "LOS VOTOS BLANCOS FUERON : ",blanco ," VOTOS";    
FinProceso