Menú de platos (PSEUDOCODIGOS DE CASOS)
Elabore un algoritmo con pseudocódigo en inter p, donde implemente la estructura de casos para que efectue lo siguiente:
A)Muestre por pantalla un menú de opciones de platos de un restaurant:
1)Pollo, Arroz, Platanos y jugo.
2)Bistek, Arroz, Platanos y Coca_Cola.
3)Pescado, Yuca,Ensaladay Papelon.
4)Sopa, Arepas, Queso y Cualquier Bebida.
B)Al ingresar una opción le pedirá el costo del plato y la cantidad de platos que desea el cliente, como asi debe calcular el total a pagar.
C)El programa mostrara el resultado, y en caso de ingresar una opción incorrecta, mostrar un mensaje de error.

1

Respuestas

2013-06-05T04:07:13+02:00
Hola, el ejercicio esta facil, solo debes pensar un poco.

Proceso menu
Escribir "Menu del dia: " ;
Escribir "1) Pollo, Arroz, Platanos y jugo" ;

Escribir "2) Bistek, Arroz, Platanos y Coca-Cola" ;

Escribir "3) Pescado, Yuca, Ensalada y Papelon" ;

Escribir "4) Sopa, Arepas, Quso y Cualquier Bebida" ;

Escribir "Ingrese la opcion que desea: " ;

Leer N ;

Segun N Hacer
1:
Escribir "Ingrese el costo del plato: " ;
Leer Costo ;

Escribir "Ingrese la cantidad de platos :" ;

Leer Platos ;

Escribir "El total a pagar es de: $", Costo * Platos ;

2: Escribir "Ingrese el costo del plato: " ;
Leer Costo ;

Escribir "Ingrese la cantidad de platos :" ;

Leer Platos ;

Escribir "El total a pagar es de: $",
Costo * Platos ;

3:
Escribir "Ingrese el costo del plato: " ;
Leer Costo ;

Escribir "Ingrese la cantidad de platos :" ;

Leer Platos ;

Escribir "El total a pagar es de: $", Costo * Platos ;

4:
Escribir "Ingrese el costo del plato: " ;
Leer Costo ;

Escribir "Ingrese la cantidad de platos :" ;

Leer Platos ;

Escribir "El total a pagar es de: $", Costo * Platos ;

De Otro Modo:
Escribir "Error en la opcion ingresada" ;

FinSegun
FinProceso