1.Dados dos número enteros, se necesita saber el resultado de dividir el cuadrado del mayor de ellos y el menor de ellos. Si los números son iguales escribir un mensaje.

2.Determinar si un número ingresado es: negativo, cero o positivo e imprimir, de acuerdo a cada caso, el mensaje correspondiente.

las 2 preguntas en diagramas de flujos

1

Respuestas

¡La mejor respuesta!
2013-05-30T00:11:16+02:00
Hola, primero dejame decirte que los ejercicios estan faciles, debes pensar un poco mas. Hice el algoritmo en pseudocodigo, espero entiendas.
1-
Proceso Mayor
Escribir "Ingrese un numero: " ;

Leer Num1 ;

Escribir "Ingrese otro numero: " ;

Leer Num2 ;

Si (Num1 > Num2) Entonces

Num3 <- Num1 * Num1 ;

Num4 <- Num3 / Num2 ;

Escribir "El resultado es: ", Num4 ;

Sino
Si (Num2 > Num1) Entonces
Num3 <- Num2 * Num2 ;

Num4 <- Num3 / Num2 ;

Escribir "El resultado es: ", Num4 ;

FinSi

FinSi
Si (Num1 = Num2)
Escribir "Los numeros son iguales" ;

FinSi
FinProceso

2-
Proceso Signos
Escribir "Ingrese un numero para evaluar: " ;

Leer N1 ;

Si (N1 > 0) Entonces

Escribir "El numero ingresado es positivo" ;

Sino
Si (N1 < 0) Entonces
Escribir "El numero ingresado es negativo" ;
Sino
Escribir "El numero ingresado es 0" ;
FinSi

FinSi
FinProceso