porfavor me colaboran con este algoritmo...ojala en pseudocódigo y como debería ir en c++...Gracias

Dada la Identificación, Nombre, y la Nota Definitiva de 30 estudiantes, realice un algoritmo que permita calcular y dar como salida lo siguiente:

• Cantidad de Alumnos Aprobados

• Cantidad de Alumnos Reprobados

• Promedio General de Notas

1

Respuestas

2013-05-02T11:22:38+02:00

pseudocodigo

Inicio
     Entero identificacion[30],i,aprobados,reprobados;

     Real calificacion[30], suma;

     Texto nombre[30];

 

     Para i=0 Hasta 29 Hacer
          Escribir "Estuadiante ",i,":";
          Escribir "Digite Identificacion:";
          Leer identificacion[i];
          Escribir "Digite Nombre:";
          Leer nombre[i];
          Escribir "Digite Calificacion:";
          Leer calificacion[i];
     FinPara
     

     aprobados=0;
     reprobados=0;
     suma=0;
     Para i=0 Hasta 29 Hacer
          Si identificacion[i]<3 Entonces
               reprobados=reprobados+1;
          Sino
               aprobados=aprobados+1;
          FinSi
          suma=suma+identificacion[i];
     FinPara
     

     Escribir "Total Aprobados: ",aprobados;
     Escribir "Total Reprobado: ",reprobados;
     Escribir "Promedio General:", suma/30;
Fin

---------------------------------------------------------------------------------------------------------

c++

#include <iostream>
#include <string>
#include <cstdlib>

using namespace std;

int main()
{
int identificacion[30], i, aprobados, reprobados;
float calificacion[30], suma;
string nombre[30];
for (i=0;i<=29;i++)
{
cout << "Estudiante "<<i+1<<":\n";
cout << "Digite Identificacion: ";
cin >> identificacion[i];
cout << "Digite Nombre: ";
cin >> nombre[i];
cout << "Digite Calificacion: ";
cin >> calificacion[i];
}

aprobados=0;
reprobados=0;
suma=0;

for (i=0;i<=29;i++)
{
if(identificacion[i]<3)
{
reprobados=reprobados+1;
}else{
aprobados=aprobados+1;
}
suma=suma+calificacion[i];
}
cout << "Total Aprobados: "<<aprobados;
cout << "\nTotal Reprobados: "<<reprobados;
cout << "\Promedio General: "<<suma/30<<"\n";
system("pause");
return 0;
}

 

Nota: La de aprovacion en este caso es de 3.0 en adelante