buenas tardes, necesito plasmar en Excel las posibles combinaciones una por una del 1 al 45 en grupos de 6 números, a sabiendas de que son mas de 8 millones, teniendo en cuenta que las celdas no alcanzan, entonces agruparlas hasta que nos den los 8 millones de resultados o combinaciones posibles... les agradecería mucho si me pueden ayudar... que formula utilizar para combinar los numeros y para que me los distribuya en filas?

1

Respuestas

2013-04-25T23:31:31+02:00

Lo solucionaría con una hoja con la siguiente información:

B1 = Elementos
C1 = Grupos de
D1 = Combinaciones

B2 = 10
C2 = 4
D2 = =COMBINAT(B2,C2)

En el rango A3 a A12 poner los elementos de los que se formarán los grupos.

B4 = 1
C4 = =B4+1
D4 = =C4+1
E4 = =D4+1
F4 = =INDIRECTO(DIRECCION(B4+2,1))
G4 = =INDIRECTO(DIRECCION(C4+2,1))
H4 = =INDIRECTO(DIRECCION(D4+2,1))
I4 = =INDIRECTO(DIRECCION(E4+2,1))

B5 = =SI(C4=$B$2-2,SI(B4+1 > $B$2-4,"TERMINE",B4+1),SI(C4=$B$2,B4+1,B…
C5 = =SI(D4=$B$2-1,SI(C4=$B$2-2,B5+1,C4+1),SI…
D5 = =SI(D4=$B$2-1,C5+1,SI(E4=$B$2,D4+1,D4))
E5 = =SI(E4=$B$2,D5+1,E4+1)
F5 = =INDIRECTO(DIRECCION(B5+2,1))
G5 = =INDIRECTO(DIRECCION(C5+2,1))
H5 = =INDIRECTO(DIRECCION(D5+2,1))
I5 = =INDIRECTO(DIRECCION(E5+2,1))

Y después copiar las celdas B5 a I5 hacia abajo hasta el renglón 212

Espero que te sea útil.