ESTE EJERCICIO ES EN EL PROGRAMA PSEINT... crear un algoritmo que calcule la raiz cuadrada del numero que introdusca el usuario. si se introduce un numero negativo, debo mostrar un mensaje de error y volver a pedirlo tantas veces como sea necesario.

PORFAVOR AYUDENME..... ES PARA MAÑANA

1

Respuestas

2013-03-13T01:39:34+01:00

Hola te aconsejo usar tu propia logica antes de pedir ayuda, espero que ya lo hayas hecho...

En todo caso, aqui esta hecho en PsEint:

 

Proceso sin_titulo
Repetir
Escribir "Ingrese el numero a evaluar: ";
Leer N1;
Si N1 < 0 Entonces
Escribir "Error, el numero es negativo, es imposible de operar.";
Sino
Raiz1 <- RC(N1);
FinSi
Escribir "La raiz de ",N1," es: ", Raiz1;
Escribir "";
Escribir "Ingrese 1 para calcular otro numero";
Escribir "Ingrese 0 para salir del programa";
Leer N2;
Limpiar Pantalla;
Hasta Que N2 = 0
FinProceso

 

Espero haber ayudado.