Respuestas

2013-03-02T04:43:49+01:00

Proceso PAtitosBuenos

         Escribir "hola, escriba el numero de patos";

         Leer NUM;

         Repetir

                   Escribir "escriba el peso del pato ", NUM;

                   NUM<-NUM-1;

                   Leer PESO;

                   Si PESO>=1.7 Y PESO<=2 Entonces

                           

                            PATOSBUENPESO<-PATOSBUENPESO+1;

                   FinSi

         Hasta Que NUM=0

         Escribir "Patos con buen peso: ",PATOSBUENPESO;

FinProceso

 

 

 

Proceso NumerosPositivos

 

            Repetir

                        Escribir NUM;

                        NUM<-NUM+2;

                       

            Hasta Que NUM=2000

           

FinProceso

 

 

 

Proceso NOTASBUENAS

           

            Repetir

                        NUM<-NUM+1;

                        Escribir "escriba la nota ", NUM;

                        Leer NOTA;

                        Si NOTA>=70 Entonces

                                   NOTASBUENAS<-NOTASBUENAS+1;

                        FinSi

            Hasta Que NUM=50

            Escribir "NOTAS MAYORES QUE 70 DUERON ", NOTASBUENAS;

FinProceso

 

 

 

Proceso ventas

            Escribir "CUÁNTAS VENTAS SE HICIERON HOY?", N;

            Repetir

                        NUM<-NUM+1;

                        Escribir "escriba el monto de la venta ", NUM;

                        Leer MONTOVENTA;

                        TOTALVENTAS<-TOTALVENTAS+MONTOVENTA;

            Hasta Que NUM=N

            Escribir "TOTAL DE VENTAS ", TOTALVENTAS;

FinProceso

 

Proceso SUMAPARES

            Repetir

                        NUM<-NUM+1;

                        SUMAPARES<-SUMAPARES+2;

            Hasta Que NUM=50

            Escribir "SUMA DE 50 PRIMEROS NUMEROS PARES ES ", SUMAPARES;

FinProceso

 

 

 

 

Proceso NumerosPOSNEGCERO

           

            Repetir

                        NUM<-NUM+1;

                        Escribir "escriba el numero ",NUM;

                        Leer NUMERO;

                        si NUMERO<0 ENTONCES

                                   NEGATIVOS<-NEGATIVOS+1;

                        Sino

                                   SI NUMERO=0 Entonces

                                               CEROS<-CEROS+1;

                                   Sino

                                               POSITIVOS<-POSITIVOS+1;

                                               SUMAPOSITIVOS<-SUMAPOSITIVOS+NUMERO;

                                   FinSi

                        FinSi

                       

            Hasta Que NUM=10

            PROMEDIOPOSITIVOS<-SUMAPOSITIVOS/POSITIVOS;

            ESCRIBIR "NEGATIVOS: ", NEGATIVOS;

            ESCRIBIR "IGUALES A CERO: ", CEROS;

            ESCRIBIR "PROMEDIO POSITIVOS: ",PROMEDIOPOSITIVOS;

           

FinProceso

 

 

Proceso INTERESSIMPLE

           

            ESCRIBIR "ESCRIBA EL CAPITAL: ";

            LEER P;

            ESCRIBIR "ESCRIBA EL INTERES: ";

            LEER I;

            ESCRIBIR "ESCRIBA LOS AÑOS: ";

            LEER N;

            A<-P*(1+I*N);

           

            ESCRIBIR "MONTO FUTURO: ",A;

           

FinProceso

 

 

 

Proceso DIVISIBLE

           

            ESCRIBIR "ESCRIBA NUMERO X ";

            LEER XX;

            XXX<-XX;

            ESCRIBIR "ESCRIBA NUMERO Y: ";

            LEER YY;

            Si YY=1 Entonces

                        ESCRIBIR "EL NUMERO ",XXX," SE PUEDE DIVIDIR INFINITAS VECES ENTRE 1";

            Sino

                        RESIDUO<-XX MOD YY;

                        Mientras RESIDUO=0 Hacer

                                   DIVISIONES<-DIVISIONES+1;

                                   COCIENTE<-XX/YY;

                                   XX<-COCIENTE;

                                   RESIDUO<-XX MOD YY;

                        FinMientras

                        ESCRIBIR "EL NUMERO ",XXX," SE PUEDE DIVIDIR ",DIVISIONES," VECES ENTRE ", YY;

            FinSi

           

FinProceso