onegaii .........en pseudocodigo

programas con vectores

1)pida 10 numeros enteros por teclado y que imprima por pantalla:

a)cuantos de esos son impares ,cuantos son pares,

b)cual valor es el maximo y

c)cual valor es minimo

2)cargar un arreglo de n numeros enteros indicar cual es el mayor de ellos y donde estas.

los kiero ñyna

1

Respuestas

2013-02-20T17:01:55+01:00

1. Pida 10 nros enteros y los imprima por pantalla:

 

Función Principal ()

Inicio

i, v[10], par, max, min: Enteros

Para i←0 hasta 9 inc1 hacer

  Escribir "Ingrese un número (", i, "): "

  Leer v[i]

  Si(v[i]%2==0) entonces par++

finPara

max←v[0]

min←v[0]

Escribir "Los números se han leído correctamente:"

Para i←0 hasta 9 inc1 hacer

  Escribir "Posición (", i, ") del vector: ", v[i]

  Si(v[i]>max) entonces max←v[i]

  Si(v[i]<min) entonces min←v[i]

finPara

Escribir "De estos números, ", par, " son pares y ", 10-par, " son impares."

Escribir "El valor máximo es ", max, " y el mínimo es ", min

Fin

 

 

2. Cargar un arreglo de N nros enteros e indicar el mayor de ellos y su posición.

 

Función Principal ()

Inicio

v[30], N, mayor, mayorPos: Enteros

Hacer

  Escribir "Ingrese un valor para N (<30): "

  Leer N

Mientras(N>30 OR N<1)

Escribir "Lectura de los ", N, " números: "

// Lectura del primer número.

Escribir "v[0] = "

Leer v[0]

mayor←v[0]

Para i←1 hasta N-1 inc1 hacer

  Escribir "v[", i, "] = "

  Leer v[i]

  Si (v[i]>mayor) entonces 

    mayor←v[i]

    mayorPos←i

  finSi

finPara

Escribir "El mayor de los nros ingresados es ", mayor, " y se encuentra en la posición ", mayorPos, " del vector."

Fin