en pseint o pseudocodigo

1) recolectar las medidas de una camisa

2)permiata determinar de n numeros el promedio de pares

3)permita presentar la suma de 4 numeros pares positivos y el producto de 3 numeros los negativos

4)encuentre y despliegue los numeros primos entre uno y cincuenta un numero primo es divisible entre el mismo y la unidad porlo tanto un numero prino no puede ser par exepto el numero 2

5)de n numeros ingresados por teclado sumar los positivos impares y determinar cuantos ceros hay

6)permita calcular los 5 numero perfectos (un numero es perfecto , cuando la suma de sus divisores, sin incluirlo al numero es exactamente el mismo numero . el 6 es un numero perfecto ya que susu divisores son 1, 2 y 3 suman 6)

1

Respuestas

2013-02-21T16:58:13+01:00

En pseudocódigo.

 

1) Recolectar las medidas de una camisa.

 Función Principal()

Inicio

cue, hom, man, cam, sis, pec, cin, cad: Float

Escribir "Porfavor ingrese los campos solicitados: "

Escribir "Cuello: "

Leer cue

Escribir "Hombros: "

Leer hom

Escribir "Largo de manga: "

Leer man

Escribir "Largo de camisa: "

Leer cam

Escribir "Sisa: "

Leer sis

Escribir "Pecho: "

Leer pec

Escribir "Cintura: "

Leer cin

Escribir "Cadera: "

Leer cad

Escribir "Las medidas se han tomado correctamente !"

Fin

 

 

2) Permita determinar de n numeros el promedio de pares.

Función Principal()

Inicio

N, i, num, sumaPares←0, cPares←0: Enteros

Escribir "Ingrese un valor para N: "

Leer N

Para i←0 hasta N-1 inc1 hacer

  Escribir "Ingrese un número: "

  Leer num

  Si (num%2==0) entonces

    sumaPares+=num

    cPares++

  finSi

finPara

Escribir "Datos leídos correctamente."

Escribir "Se encontraron ", cPares, " números pares."

Escribir "El promedio de los pares es: ", sumaPares/cPares

Fin

 

3) Permita presentar la suma de 4 numeros pares positivos y el producto de 3 numeros negativos.

 

Función Principal ()

Inicio

pares[4], i, sumaP←0, neg[3], prodN←1: Enteros

Escribir "Suma de 4 números pares positivos."

Para i←0 hasta 3 inc1 hacer

  Hacer

    Escribir "Ingrese un número par positivo (", i, "): "

    Leer pares[i]

  Mientras(pares[i]%2==1 OR pares[i]<0)

  sumaP+=pares[i]

finPara

Escribir "Suma de los 4 nros pares positivos ingresados: ", sumaP

Escribir "Producto de 3 números negativos."

Para i←0 hasta 2 inc1 hacer

  Hacer

    Escribir "Ingrese un número negativo (", i, "): "

    Leer neg[i]

  Mientras(neg>0)

  prodN*=neg[i]

finPara

Escribir "Producto de los 3 nros negativos ingresados: ", prodN

Fin

 

5) De n numeros ingresados por teclado sumar los positivos impares y determinar cuantos ceros hay.

 

Función Principal ()

Inicio

N, v[30], nulos←0, SumaPosImp←0: Entero

Escribir "Ingrese un valor para N (<30): "

Leer N

Para i←0 hasta N-1 inc1 hacer

  Escribir "Ingrese un número para v[", i, "]: "

  Leer v[i]

  Si (v[i]==0) entonces

    nulos++

  Sino

    Si(v[i]>0 AND v[i]%2==1) entonces

      SumaPosImp+=v[i]

    finSi

  finSi

finPara

Escribir "Cantidad de ceros encontrados: ", nulos

Escribir "Suma de los nros positivos impares: ", SumaPosImp

Fin